aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-12 14:31:40 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 10:23:43 +0100
commitd6de31310cc1924ff077f4f143efa6496e3323aa (patch)
tree8832086a7a80f844e487380f942f3da1d0d4d0ea /tools/cmake/Makefile
parent83eef37400addfffe936959c10f2b2a8c1388907 (diff)
downloadupstream-d6de31310cc1924ff077f4f143efa6496e3323aa.tar.gz
upstream-d6de31310cc1924ff077f4f143efa6496e3323aa.tar.bz2
upstream-d6de31310cc1924ff077f4f143efa6496e3323aa.zip
cmake: restore parallel build support for bootstrap
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/cmake/Makefile')
-rw-r--r--tools/cmake/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index a1137c5b50..c56cd40fb5 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -20,7 +20,9 @@ HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_CMD := \
- MAKEFLAGS="$(HOST_JOBS)" $(BASH) ./configure
+ MAKEFLAGS="$(HOST_JOBS)" \
+ $(BASH) ./configure \
+ $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
HOST_CONFIGURE_VARS :=