aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-12 14:31:40 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 10:23:43 +0100
commitd6de31310cc1924ff077f4f143efa6496e3323aa (patch)
tree8832086a7a80f844e487380f942f3da1d0d4d0ea /tools/cmake
parent83eef37400addfffe936959c10f2b2a8c1388907 (diff)
downloadupstream-d6de31310cc1924ff077f4f143efa6496e3323aa.tar.gz
upstream-d6de31310cc1924ff077f4f143efa6496e3323aa.tar.bz2
upstream-d6de31310cc1924ff077f4f143efa6496e3323aa.zip
cmake: restore parallel build support for bootstrap
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile4
-rw-r--r--tools/cmake/patches/150-bootstrap_parallel_make_flag.patch14
2 files changed, 17 insertions, 1 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index a1137c5b50..c56cd40fb5 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -20,7 +20,9 @@ HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_CMD := \
- MAKEFLAGS="$(HOST_JOBS)" $(BASH) ./configure
+ MAKEFLAGS="$(HOST_JOBS)" \
+ $(BASH) ./configure \
+ $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
HOST_CONFIGURE_VARS :=
diff --git a/tools/cmake/patches/150-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/150-bootstrap_parallel_make_flag.patch
new file mode 100644
index 0000000000..6970b83b32
--- /dev/null
+++ b/tools/cmake/patches/150-bootstrap_parallel_make_flag.patch
@@ -0,0 +1,14 @@
+--- a/bootstrap
++++ b/bootstrap
+@@ -958,7 +958,10 @@ int main(){ printf("1%c", (char)0x0a); r
+ ' > "test.c"
+ cmake_original_make_flags="${cmake_make_flags}"
+ if [ "x${cmake_parallel_make}" != "x" ]; then
+- cmake_make_flags="${cmake_make_flags} -j ${cmake_parallel_make}"
++ case "$cmake_paralle_make" in
++ [0-9]*) cmake_parallel_make="-j ${cmake_parallel_make}";;
++ esac
++ cmake_make_flags="${cmake_make_flags} ${cmake_parallel_make}"
+ fi
+ for a in ${cmake_make_processors}; do
+ if [ -z "${cmake_make_processor}" ] && cmake_try_make "${a}" "${cmake_make_flags}" >> ../cmake_bootstrap.log 2>&1; then