aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a7.mk
diff options
context:
space:
mode:
authorAleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>2019-03-01 20:30:47 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-03-09 18:55:15 +0100
commit445ca981d163d54c8dcf16cf206bc44904160b99 (patch)
treeb50165d3b243c5711d37972d62f6f43453bf1d61 /target/linux/sunxi/image/cortex-a7.mk
parentd971ae51a51cb1b145b6fbbf7d1327a99be257b1 (diff)
downloadupstream-445ca981d163d54c8dcf16cf206bc44904160b99.tar.gz
upstream-445ca981d163d54c8dcf16cf206bc44904160b99.tar.bz2
upstream-445ca981d163d54c8dcf16cf206bc44904160b99.zip
sunxi: add support for Orange Pi PC Plus
CPU: H3 Quad-core Cortex-A7 H.265/HEVC 4K @ 1.2 Ghz GPU: Mali400MP2 GPU @ 600MHz (supports OpenGL ES 2.0) Memory: 1GB DDR3 (shared with GPU) Onboard: Storage TF card (Max. 64GB) / MMC card slot Onboard: Storage 8 GB eMMC Onboard: Network 10/100M Ethernet RJ45 Onboard: Network WiFi 802.11 b/g/n (Realtek RTL8189FTV) Onboard header: SPI, I2C, GPIO, UART USB 2.0: Three USB 2.0 HOST, One USB 2.0 OTG Known issues: -Wifi diesn't work Signed-off-by: Aleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a7.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index a9045c7d5a..ce0cbe5a5c 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -179,6 +179,16 @@ endef
TARGET_DEVICES += sun8i-h3-orangepi-pc
+define Device/sun8i-h3-orangepi-pc-plus
+ DEVICE_TITLE:=Xunlong Orange Pi PC Plus
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+ SUPPORTED_DEVICES:=xunlong,orangepi-pc-plus
+ SUNXI_DTS:=sun8i-h3-orangepi-pc-plus
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-pc-plus
+
+
define Device/sun8i-h3-orangepi-plus
DEVICE_TITLE:=Xunlong Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi