aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-sunxi/Makefile7
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk10
2 files changed, 17 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 1e3883dfb4..ecead6ef12 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -168,6 +168,12 @@ define U-Boot/orangepi_pc
BUILD_DEVICES:=sun8i-h3-orangepi-pc
endef
+define U-Boot/orangepi_pc_plus
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Orange Pi PC Plus (H3)
+ BUILD_DEVICES:=sun8i-h3-orangepi-pc-plus
+endef
+
define U-Boot/orangepi_plus
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi Plus (H3)
@@ -268,6 +274,7 @@ UBOOT_TARGETS := \
orangepi_r1 \
orangepi_one \
orangepi_pc \
+ orangepi_pc_plus \
orangepi_plus \
orangepi_2 \
orangepi_pc2 \
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index a9045c7d5a..ce0cbe5a5c 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -179,6 +179,16 @@ endef
TARGET_DEVICES += sun8i-h3-orangepi-pc
+define Device/sun8i-h3-orangepi-pc-plus
+ DEVICE_TITLE:=Xunlong Orange Pi PC Plus
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+ SUPPORTED_DEVICES:=xunlong,orangepi-pc-plus
+ SUNXI_DTS:=sun8i-h3-orangepi-pc-plus
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-pc-plus
+
+
define Device/sun8i-h3-orangepi-plus
DEVICE_TITLE:=Xunlong Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi