aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-04-30 12:27:09 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-14 21:16:20 +0200
commitc5356d10c0e67284ea2087fcbc619af5e9fc9e8f (patch)
tree4bdfddc81836f25c8950e735d98ac2129364ea21 /target/linux/kirkwood
parent73c3ba23a4cf973ca03e0e1ec0d4afa306fb7659 (diff)
downloadupstream-c5356d10c0e67284ea2087fcbc619af5e9fc9e8f.tar.gz
upstream-c5356d10c0e67284ea2087fcbc619af5e9fc9e8f.tar.bz2
upstream-c5356d10c0e67284ea2087fcbc619af5e9fc9e8f.zip
kirkwood: move mmc/sd features to modules
All devices are using nand images. Built-in MMC/SD modules are not needed anymore. Run tested: pogo v4 Reviewed-by: Sungbo Eo <mans0n@gorani.run> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/config-5.43
-rw-r--r--target/linux/kirkwood/image/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/kirkwood/config-5.4 b/target/linux/kirkwood/config-5.4
index 4be83a5139..da03efa94c 100644
--- a/target/linux/kirkwood/config-5.4
+++ b/target/linux/kirkwood/config-5.4
@@ -221,9 +221,6 @@ CONFIG_MDIO_BUS=y
CONFIG_MDIO_DEVICE=y
CONFIG_MEMFD_CREATE=y
CONFIG_MIGRATION=y
-CONFIG_MMC=y
-CONFIG_MMC_BLOCK=y
-CONFIG_MMC_MVSDIO=y
# CONFIG_MMC_TIFM_SD is not set
CONFIG_MODULES_USE_ELF_REL=y
# CONFIG_MTD_CFI is not set
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 76dfc4ea09..85bf0118ac 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -36,6 +36,7 @@ define Device/cisco_on100
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
BOARD_NAME := on100
+ DEVICE_PACKAGES := kmod-mvsdio
endef
TARGET_DEVICES += cisco_on100
@@ -50,7 +51,7 @@ define Device/cloudengines_pogoplugv4
DEVICE_VENDOR := Cloud Engines
DEVICE_MODEL := Pogoplug V4
DEVICE_DTS := kirkwood-pogoplug-series-4
- DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-mvsdio kmod-usb3
endef
TARGET_DEVICES += cloudengines_pogoplugv4