aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk17
-rw-r--r--target/linux/kirkwood/config-5.43
-rw-r--r--target/linux/kirkwood/image/Makefile3
3 files changed, 19 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 2cd4765196..936a1327fd 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -391,6 +391,23 @@ endef
$(eval $(call KernelPackage,mmc))
+define KernelPackage/mvsdio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell MMC/SD/SDIO host driver
+ DEPENDS:=+kmod-mmc @TARGET_kirkwood
+ KCONFIG:= CONFIG_MMC_MVSDIO
+ FILES:= \
+ $(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+ AUTOLOAD:=$(call AutoProbe,mvsdio,1)
+endef
+
+define KernelPackage/mvsdio/description
+ Kernel support for the Marvell SDIO host driver.
+endef
+
+$(eval $(call KernelPackage,mvsdio))
+
+
define KernelPackage/sdhci
SUBMENU:=$(OTHER_MENU)
TITLE:=Secure Digital Host Controller Interface support
diff --git a/target/linux/kirkwood/config-5.4 b/target/linux/kirkwood/config-5.4
index 4be83a5139..da03efa94c 100644
--- a/target/linux/kirkwood/config-5.4
+++ b/target/linux/kirkwood/config-5.4
@@ -221,9 +221,6 @@ CONFIG_MDIO_BUS=y
CONFIG_MDIO_DEVICE=y
CONFIG_MEMFD_CREATE=y
CONFIG_MIGRATION=y
-CONFIG_MMC=y
-CONFIG_MMC_BLOCK=y
-CONFIG_MMC_MVSDIO=y
# CONFIG_MMC_TIFM_SD is not set
CONFIG_MODULES_USE_ELF_REL=y
# CONFIG_MTD_CFI is not set
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 76dfc4ea09..85bf0118ac 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -36,6 +36,7 @@ define Device/cisco_on100
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
BOARD_NAME := on100
+ DEVICE_PACKAGES := kmod-mvsdio
endef
TARGET_DEVICES += cisco_on100
@@ -50,7 +51,7 @@ define Device/cloudengines_pogoplugv4
DEVICE_VENDOR := Cloud Engines
DEVICE_MODEL := Pogoplug V4
DEVICE_DTS := kirkwood-pogoplug-series-4
- DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-mvsdio kmod-usb3
endef
TARGET_DEVICES += cloudengines_pogoplugv4