aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-04-30 12:18:24 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-14 21:16:20 +0200
commit73c3ba23a4cf973ca03e0e1ec0d4afa306fb7659 (patch)
tree0d75550c728ceb4cec115fab36ce0a43b619cfba /target/linux/kirkwood
parentbbe712494596cc4a7c317b73ffdf800f04641912 (diff)
downloadupstream-73c3ba23a4cf973ca03e0e1ec0d4afa306fb7659.tar.gz
upstream-73c3ba23a4cf973ca03e0e1ec0d4afa306fb7659.tar.bz2
upstream-73c3ba23a4cf973ca03e0e1ec0d4afa306fb7659.zip
kirkwood: move sata features to modules
All devices are using nand images. Built-in SATA modules are not needed anymore. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> [only move CONFIG_SATA_MV] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Pawel Dembicki <paweldembicki@gmail.com> [pogo v4]
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/config-5.41
-rw-r--r--target/linux/kirkwood/image/Makefile14
2 files changed, 10 insertions, 5 deletions
diff --git a/target/linux/kirkwood/config-5.4 b/target/linux/kirkwood/config-5.4
index c14ca3778f..4be83a5139 100644
--- a/target/linux/kirkwood/config-5.4
+++ b/target/linux/kirkwood/config-5.4
@@ -305,7 +305,6 @@ CONFIG_REGULATOR_FIXED_VOLTAGE=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_DRV_MV=y
CONFIG_RTC_I2C_AND_SPI=y
-CONFIG_SATA_MV=y
CONFIG_SATA_PMP=y
CONFIG_SCSI=y
CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 552ee44ee4..76dfc4ea09 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -50,7 +50,7 @@ define Device/cloudengines_pogoplugv4
DEVICE_VENDOR := Cloud Engines
DEVICE_MODEL := Pogoplug V4
DEVICE_DTS := kirkwood-pogoplug-series-4
- DEVICE_PACKAGES := kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-usb3
endef
TARGET_DEVICES += cloudengines_pogoplugv4
@@ -65,7 +65,8 @@ define Device/iom_ix2-200
DEVICE_VENDOR := Iomega
DEVICE_MODEL := StorCenter ix2-200
DEVICE_DTS := kirkwood-iomega_ix2_200
- DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-hwmon-lm63
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
+ kmod-hwmon-lm63
PAGESIZE := 512
SUBPAGESIZE := 256
BLOCKSIZE := 16k
@@ -110,6 +111,7 @@ define Device/raidsonic_ib-nas62x0
DEVICE_VENDOR := RaidSonic
DEVICE_MODEL := ICY BOX IB-NAS62x0
BOARD_NAME := ib62x0
+ DEVICE_PACKAGES := kmod-ata-marvell-sata
endef
TARGET_DEVICES += raidsonic_ib-nas62x0
@@ -124,6 +126,7 @@ define Device/seagate_goflexnet
DEVICE_VENDOR := Seagate
DEVICE_MODEL := GoFlexNet
BOARD_NAME := goflexnet
+ DEVICE_PACKAGES := kmod-ata-marvell-sata
endef
TARGET_DEVICES += seagate_goflexnet
@@ -131,13 +134,15 @@ define Device/seagate_goflexhome
DEVICE_VENDOR := Seagate
DEVICE_MODEL := GoFlexHome
BOARD_NAME := goflexhome
+ DEVICE_PACKAGES := kmod-ata-marvell-sata
endef
TARGET_DEVICES += seagate_goflexhome
define Device/zyxel_nsa310b
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NSA310b
- DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-r8169 \
+ kmod-gpio-button-hotplug kmod-hwmon-lm85
BOARD_NAME := nsa310b
endef
TARGET_DEVICES += zyxel_nsa310b
@@ -146,7 +151,8 @@ define Device/zyxel_nsa325
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NSA325
DEVICE_VARIANT := v1/v2
- DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
+ kmod-rtc-pcf8563 kmod-usb3
BOARD_NAME := nsa325
endef
TARGET_DEVICES += zyxel_nsa325