aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorRoberto Valentini <valantin89@gmail.com>2021-07-01 11:56:30 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-07-11 16:58:12 +0200
commitaf56075a8ff760832df27546325428f2497a0121 (patch)
tree10adbb81fee0b99358d8439a2141253eae8b259c /target/linux/ath79/image/generic-tp-link.mk
parent0c721434ea56044cdc1c13554c970b82471bc43e (diff)
downloadupstream-af56075a8ff760832df27546325428f2497a0121.tar.gz
upstream-af56075a8ff760832df27546325428f2497a0121.tar.bz2
upstream-af56075a8ff760832df27546325428f2497a0121.zip
ath79: add support for TP-Link RE455 v1
TP-Link RE455 v1 is a dual band router/range-extender based on Qualcomm/Atheros QCA9563 + QCA9880. This device is nearly identical to RE450 v3 Specification: - 775 MHz CPU - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 3T3R 5 GHz - 1x 10/100/1000 Mbps Ethernet (AR8033 PHY) - 7x LED, 4x button - UART header on PCB[1] Flash instruction: Apply factory image in OEM firmware web-gui. [1] Didn't work, probably need to short unpopulated resistor R64 and R69 as RE450v3 Signed-off-by: Roberto Valentini <valantin89@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 9c4920b4e6..16494b111f 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -486,6 +486,18 @@ define Device/tplink_re450-v3
endef
TARGET_DEVICES += tplink_re450-v3
+define Device/tplink_re455-v1
+ $(Device/tplink-safeloader)
+ SOC := qca9563
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := RE455
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
+ TPLINK_BOARD_ID := RE455-V1
+ LOADER_TYPE := elf
+endef
+TARGET_DEVICES += tplink_re455-v1
+
define Device/tplink_tl-mr6400-v1
$(Device/tplink-8mlzma)
SOC := qca9531