aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 9c4920b4e6..16494b111f 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -486,6 +486,18 @@ define Device/tplink_re450-v3
endef
TARGET_DEVICES += tplink_re450-v3
+define Device/tplink_re455-v1
+ $(Device/tplink-safeloader)
+ SOC := qca9563
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := RE455
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
+ TPLINK_BOARD_ID := RE455-V1
+ LOADER_TYPE := elf
+endef
+TARGET_DEVICES += tplink_re455-v1
+
define Device/tplink_tl-mr6400-v1
$(Device/tplink-8mlzma)
SOC := qca9531