aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/config
diff options
context:
space:
mode:
authorleo chung <gewalalb@gmail.com>2019-09-20 13:33:58 +0800
committerPetr Štetiar <ynezz@true.cz>2019-09-25 12:50:24 +0200
commitb2c55d50f8aeb21ef4cd3948034a158f7dd743c2 (patch)
treefce27ac18b161ab2a310075f8fab1a52a341c214 /scripts/config
parent965f341aa9fdb6e07d509d02a6ca188af050292a (diff)
downloadupstream-b2c55d50f8aeb21ef4cd3948034a158f7dd743c2.tar.gz
upstream-b2c55d50f8aeb21ef4cd3948034a158f7dd743c2.tar.bz2
upstream-b2c55d50f8aeb21ef4cd3948034a158f7dd743c2.zip
build: fix xconfig target
`make xconfig` fails with following linking error of qconf binary: g++ -lQt5Widgets -lQt5Gui -lQt5Core -o qconf qconf.o zconf.tab.o /usr/bin/ld: qconf.o: in function ConfigList::metaObject() const': qconf.cc:(.text+0x3eb): undefined reference to QObjectData::dynamicMetaObject() const' /usr/bin/ld: qconf.o: in function `ConfigList::qt_metacast(char const*)': link error. which is caused by the wrong order of the linked objects/libraries so this patch reorders the linker's arguments which makes the qconf compile again. Signed-off-by: leo chung <gewalalb@gmail.com> [commit subject and message tweaks, whitespace fix] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'scripts/config')
-rw-r--r--scripts/config/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index 8b78d5a682..0eac8edd22 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -40,7 +40,7 @@ mconf: $(mconf-objs) $(lxdialog-objs)
$(CC) -o $@ $^ $(call check_lxdialog,ldflags $(CC))
qconf: $(qconf-cxxobjs) $(qconf-objs)
ifneq ($(DISTRO-PKG-CONFIG),)
- $(CXX) $(HOSTLOADLIBES_qconf) -o $@ $^
+ $(CXX) -o $@ $^ $(HOSTLOADLIBES_qconf)
else
echo "You don't have 'pkg-config' installed. Cannot continue"
echo "For now, you may use 'make menuconfig' instead of 'make xconfig'"