aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/config
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-09-20 14:54:56 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-25 12:50:24 +0200
commit965f341aa9fdb6e07d509d02a6ca188af050292a (patch)
tree2b9cf2043cf64d6012c3a8a7aaceb076fce103a9 /scripts/config
parent661e37ccea2eb11714daf927cbaa58a8b8ff09df (diff)
downloadupstream-965f341aa9fdb6e07d509d02a6ca188af050292a.tar.gz
upstream-965f341aa9fdb6e07d509d02a6ca188af050292a.tar.bz2
upstream-965f341aa9fdb6e07d509d02a6ca188af050292a.zip
build: fix host menu config targets using ncurses
On a recent Gentoo Linux installation, invoking `make menuconfig`, `make kernel_menuconfig` or `make kernel_nconfig` in the build system fails, whereas for example `make menuconfig` in the kernel tree alone works as expected. This is happening because STAGING_PREFIX is not defined when kernel's {menu,n}config target calls pkg-config from the toolchain/host and thus pkg-config returns an empty value, and the fallback values in the kernel config script are applied but those are off and the linking fails. Solution is to use system's pkg-config for all ncurses based menu config targets in order to provide proper compiler/linker flags. Ref: FS#2423 Cc: Thomas Albers <thomas.gameiro@gmail.com> Tested-by: Stijn Tintel <stijn@linux-ipv6.be> Tested-by: Eneas U de Queiroz <cotequeiroz@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'scripts/config')
-rw-r--r--scripts/config/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index 8bb62d233c..8b78d5a682 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -20,8 +20,6 @@ check_lxdialog = $(shell $(SHELL) $(CURDIR)/lxdialog/check-lxdialog.sh -$(1))
export CFLAGS += -DKBUILD_NO_NLS -I. $(call check_lxdialog,ccflags)
export CXXFLAGS += -DKBUILD_NO_NLS
-DISTRO-PKG-CONFIG := $(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
-
conf-objs := conf.o zconf.tab.o
mconf-objs := mconf.o zconf.tab.o
qconf-cxxobjs := qconf.o