aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-06 14:24:43 -0700
committerFelix Fietkau <nbd@nbd.name>2021-06-12 10:46:39 +0200
commit09de28090cfb3fb605e6f4b452503a4ec2c6c43f (patch)
tree0b6fbc87a8a72c03e9b5e524e0cbe44278965471 /package/system
parent97258f53634d7237a2962aec3387f011047ce83b (diff)
downloadupstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.tar.gz
upstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.tar.bz2
upstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.zip
package: fix cmake packages build with ninja
+= is needed for CMAKE_OPTIONS. mt76 needs Ninja disabled as the kernel stuff uses normal make. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/ubus/Makefile2
-rw-r--r--package/system/uci/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/system/ubus/Makefile b/package/system/ubus/Makefile
index 885307107b..a29521e9a5 100644
--- a/package/system/ubus/Makefile
+++ b/package/system/ubus/Makefile
@@ -53,7 +53,7 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include -flto
TARGET_LDFLAGS += -flto
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
-DLUAPATH=/usr/lib/lua \
-DABIVERSION="$(PKG_ABI_VERSION)"
diff --git a/package/system/uci/Makefile b/package/system/uci/Makefile
index 3c1e168717..cdb6883bc1 100644
--- a/package/system/uci/Makefile
+++ b/package/system/uci/Makefile
@@ -55,7 +55,7 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
-DLUAPATH=/usr/lib/lua \
$(if $(DEBUG),-DUCI_DEBUG=ON)