aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-06 14:24:43 -0700
committerFelix Fietkau <nbd@nbd.name>2021-06-12 10:46:39 +0200
commit09de28090cfb3fb605e6f4b452503a4ec2c6c43f (patch)
tree0b6fbc87a8a72c03e9b5e524e0cbe44278965471
parent97258f53634d7237a2962aec3387f011047ce83b (diff)
downloadupstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.tar.gz
upstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.tar.bz2
upstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.zip
package: fix cmake packages build with ninja
+= is needed for CMAKE_OPTIONS. mt76 needs Ninja disabled as the kernel stuff uses normal make. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--package/kernel/mt76/Makefile1
-rw-r--r--package/libs/libubox/Makefile2
-rw-r--r--package/network/services/uhttpd/Makefile2
-rw-r--r--package/system/ubus/Makefile2
-rw-r--r--package/system/uci/Makefile2
5 files changed, 5 insertions, 4 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index e4051d8347..74d5950545 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -13,6 +13,7 @@ PKG_SOURCE_VERSION:=22b690334c0f49b11534cc2e331c9d5e17c4a0bc
PKG_MIRROR_HASH:=ff5e563935919d2e40c1e7254ef3bc06f7ecc5e69f8ddd12903e8f5de942d630
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_USE_NINJA:=0
PKG_BUILD_PARALLEL:=1
PKG_CONFIG_DEPENDS += \
diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index ac4effb6f8..aec4c9cc02 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -67,7 +67,7 @@ define Package/libubox-lua
endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
-DLUAPATH=/usr/lib/lua \
-DABIVERSION="$(PKG_ABI_VERSION)"
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 87b3690515..8f58271127 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -85,7 +85,7 @@ endif
TARGET_LDFLAGS += -lcrypt
-CMAKE_OPTIONS = -DTLS_SUPPORT=on
+CMAKE_OPTIONS += -DTLS_SUPPORT=on
define Package/uhttpd/install
$(INSTALL_DIR) $(1)/etc/init.d
diff --git a/package/system/ubus/Makefile b/package/system/ubus/Makefile
index 885307107b..a29521e9a5 100644
--- a/package/system/ubus/Makefile
+++ b/package/system/ubus/Makefile
@@ -53,7 +53,7 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include -flto
TARGET_LDFLAGS += -flto
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
-DLUAPATH=/usr/lib/lua \
-DABIVERSION="$(PKG_ABI_VERSION)"
diff --git a/package/system/uci/Makefile b/package/system/uci/Makefile
index 3c1e168717..cdb6883bc1 100644
--- a/package/system/uci/Makefile
+++ b/package/system/uci/Makefile
@@ -55,7 +55,7 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
-DLUAPATH=/usr/lib/lua \
$(if $(DEBUG),-DUCI_DEBUG=ON)