aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorYen-Ting-Shen <frank.shen@senao.com>2019-11-01 14:00:40 +0800
committerChristian Lamparter <chunkeey@gmail.com>2020-01-26 01:20:45 +0100
commit51f30359783938a1be7ffbd08e508c1b6c9c449f (patch)
treef5e859036259e4a01e4b0686fb88155e781675e1 /package/firmware
parent52b8c7a8928ccdc80436c76955f237960ea3bf1f (diff)
downloadupstream-51f30359783938a1be7ffbd08e508c1b6c9c449f.tar.gz
upstream-51f30359783938a1be7ffbd08e508c1b6c9c449f.tar.bz2
upstream-51f30359783938a1be7ffbd08e508c1b6c9c449f.zip
ipq40xx: add support for EnGenius EMD1
SOC: IPQ4018 / QCA Dakota CPU: Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7 DRAM: 256 MiB NOR: 32 MiB ETH: Qualcomm Atheros QCA8072 (1 port) WLAN1: Qualcomm Atheros QCA4018 2.4GHz 802.11bgn 2:2x2 WLAN2: Qualcomm Atheros QCA4018 5GHz 802.11a/n/ac 2:2x2 INPUT: RESET Button LEDS: White, Blue, Red, Orange Flash instruction: From EnGenius firmware to OpenWrt firmware: In Firmware Upgrade page, upgrade your openwrt-ipq40xx-generic-engenius_emd1-squashfs-factory.bin directly. From OpenWrt firmware to EnGenius firmware: 1. Setup a TFTP server on your computer and configure static IP to 192.168.99.8 Put the EnGenius firmware in the TFTP server directory on your computer. 2. Power up EMD1. Press 4 and then press any key to enter u-boot. 3. Download EnGenius firmware (IPQ40xx) # tftpboot 0x84000000 openwrt-ipq40xx-emd1-nor-fw-s.img 4. Flash the firmware (IPQ40xx) # imgaddr=0x84000000 && source 0x84000000:script 5. Reboot (IPQ40xx) # reset Signed-off-by: Yen-Ting-Shen <frank.shen@senao.com> [removed BOARD_NAME] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ipq-wifi/Makefile2
-rw-r--r--package/firmware/ipq-wifi/board-engenius_emd1.qca4019bin0 -> 24316 bytes
2 files changed, 2 insertions, 0 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index 065cda160d..eada8baf6f 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -28,6 +28,7 @@ ALLWIFIBOARDS:= \
aruba_ap-303 \
avm_fritzrepeater-1200 \
dlink_dap2610 \
+ engenius_emd1 \
ezviz_cs-w3-wd1200g-eup \
linksys_ea8300 \
qxwlan_e2600ac
@@ -96,6 +97,7 @@ endef
$(eval $(call generate-ipq-wifi-package,aruba_ap-303,Aruba AP-303))
$(eval $(call generate-ipq-wifi-package,avm_fritzrepeater-1200,AVM FRITZRepeater 1200))
$(eval $(call generate-ipq-wifi-package,dlink_dap2610,D-Link DAP-2610))
+$(eval $(call generate-ipq-wifi-package,engenius_emd1,EnGenius EMD1))
$(eval $(call generate-ipq-wifi-package,ezviz_cs-w3-wd1200g-eup,EZVIZ CS-W3-WD1200G EUP))
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
$(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac,Qxwlan E2600AC))
diff --git a/package/firmware/ipq-wifi/board-engenius_emd1.qca4019 b/package/firmware/ipq-wifi/board-engenius_emd1.qca4019
new file mode 100644
index 0000000000..3a2d77597d
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-engenius_emd1.qca4019
Binary files differ