aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFredrik Olofsson <fredrik.olofsson@anyfinetworks.com>2019-09-10 11:25:53 +0200
committerChristian Lamparter <chunkeey@gmail.com>2020-01-26 01:20:45 +0100
commit52b8c7a8928ccdc80436c76955f237960ea3bf1f (patch)
tree24a4bd67fd44b5c316fb05aad8aa7870ea39d76b /package/firmware
parentb77ce0c7209ee26aed271f894ac1580dce45db0c (diff)
downloadupstream-52b8c7a8928ccdc80436c76955f237960ea3bf1f.tar.gz
upstream-52b8c7a8928ccdc80436c76955f237960ea3bf1f.tar.bz2
upstream-52b8c7a8928ccdc80436c76955f237960ea3bf1f.zip
ipq40xx: Add support for D-Link DAP-2610
Specifications ============== - SOC: IPQ4018 - RAM: DDR3 256MB - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: IPQ4018, 2x2, front end SKY85303-11 - 5GHz: IPQ4018, 2x2, front end SKY85717-21 - Ethernet: 1x 10/100/1000Mbps, POE 802.3af - PHY: QCA8072 - UART: GND, blocked, 3.3V, RX, TX / 115200 8N1 - LED: 1x red / green - Button: 1x reset / factory default - U-Boot bootloader with tftp and "emergency web server" accessible using serial port. Installation ============ Flash factory image from D-Link web UI. Constraints in the D-Link web UI makes the factory image unnecessarily large. Flash again using sysupgrade from inside OpenWrt to reclaim some flash space. Return to stock D-Link firmware =============================== Partition layout is preserved, and it is possible to return to the stock firmware simply by downloading it from D-Link and writing it to the firmware partition. # mtd -r write dap2610-firmware.bin firmware Quirks ====== To be flashable from the D-Link http server, the firmware must be larger then 6MB, and the size in the firmware header must match the actual file size. Also, the boot loader verifies the checksum of the firmware before each boot, thus the jffs2 must be after the checksum covered part. This is solved in the factory image by having the rootfs at the very end of the image (without pad-rootfs). The sysupgrade image which does not have to be flashable from the D-Link web UI may be smaller, and the checksum in the firmware header only covers the kernel part of the image. Signed-off-by: Fredrik Olofsson <fredrik.olofsson@anyfinetworks.com> [added WRGG Variables to DEVICE_VARS, squashed spi pinconf/mux, added emd1's gmac0 config,fix dtc warnings] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ipq-wifi/Makefile5
-rw-r--r--package/firmware/ipq-wifi/board-dlink_dap2610.qca4019bin0 -> 24316 bytes
2 files changed, 4 insertions, 1 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index 161954fa1f..065cda160d 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -14,6 +14,8 @@ endef
define Build/Compile
endef
+# Use ath10k-bdencoder from https://github.com/qca/qca-swiss-army-knife.git
+# to generate the board-* files here.
#
# This is intended to be used on an interim basis until device-specific
# board data for new devices is available through the upstream compilation
@@ -21,11 +23,11 @@ endef
# Please send a mail with your device-specific board files upstream.
# You can find instructions and examples on the linux-wireless wiki:
# <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
-#
ALLWIFIBOARDS:= \
aruba_ap-303 \
avm_fritzrepeater-1200 \
+ dlink_dap2610 \
ezviz_cs-w3-wd1200g-eup \
linksys_ea8300 \
qxwlan_e2600ac
@@ -93,6 +95,7 @@ endef
$(eval $(call generate-ipq-wifi-package,aruba_ap-303,Aruba AP-303))
$(eval $(call generate-ipq-wifi-package,avm_fritzrepeater-1200,AVM FRITZRepeater 1200))
+$(eval $(call generate-ipq-wifi-package,dlink_dap2610,D-Link DAP-2610))
$(eval $(call generate-ipq-wifi-package,ezviz_cs-w3-wd1200g-eup,EZVIZ CS-W3-WD1200G EUP))
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
$(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac,Qxwlan E2600AC))
diff --git a/package/firmware/ipq-wifi/board-dlink_dap2610.qca4019 b/package/firmware/ipq-wifi/board-dlink_dap2610.qca4019
new file mode 100644
index 0000000000..08ed731a4c
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-dlink_dap2610.qca4019
Binary files differ