aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt3883/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/rt3883/profiles')
-rw-r--r--target/linux/ramips/rt3883/profiles/00-default.mk16
-rw-r--r--target/linux/ramips/rt3883/profiles/asus.mk16
-rw-r--r--target/linux/ramips/rt3883/profiles/d-link.mk16
-rw-r--r--target/linux/ramips/rt3883/profiles/edimax.mk16
-rw-r--r--target/linux/ramips/rt3883/profiles/omnima.mk16
-rw-r--r--target/linux/ramips/rt3883/profiles/samsung.mk16
-rw-r--r--target/linux/ramips/rt3883/profiles/trendnet.mk27
7 files changed, 123 insertions, 0 deletions
diff --git a/target/linux/ramips/rt3883/profiles/00-default.mk b/target/linux/ramips/rt3883/profiles/00-default.mk
new file mode 100644
index 0000000..7007c5d
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/rt3883/profiles/asus.mk b/target/linux/ramips/rt3883/profiles/asus.mk
new file mode 100644
index 0000000..4c652df
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/asus.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RTN56U
+ NAME:=Asus RT-N56U
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+
+define Profile/RTN56U/Description
+ Package set compatible with the Asus RT-N56U board.
+endef
+$(eval $(call Profile,RTN56U))
diff --git a/target/linux/ramips/rt3883/profiles/d-link.mk b/target/linux/ramips/rt3883/profiles/d-link.mk
new file mode 100644
index 0000000..6c2636a
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/d-link.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DIR645
+ NAME:=D-Link DIR-645
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+
+define Profile/DIR645/Description
+ Package set compatible with the D-Link DIR-645 board.
+endef
+$(eval $(call Profile,DIR645))
diff --git a/target/linux/ramips/rt3883/profiles/edimax.mk b/target/linux/ramips/rt3883/profiles/edimax.mk
new file mode 100644
index 0000000..b807c2c
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/edimax.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BR6475ND
+ NAME:=Edimax BR-6475nD
+ PACKAGES:=swconfig
+endef
+
+define Profile/BR6475ND/Description
+ Package set compatible with the Edimax BR-6475nD board.
+endef
+$(eval $(call Profile,BR6475ND))
diff --git a/target/linux/ramips/rt3883/profiles/omnima.mk b/target/linux/ramips/rt3883/profiles/omnima.mk
new file mode 100644
index 0000000..ce25999
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/omnima.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HPM
+ NAME:=Omnima HPM
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/HPM/Description
+ Package set compatible with the Omnima HPM board.
+endef
+$(eval $(call Profile,HPM))
diff --git a/target/linux/ramips/rt3883/profiles/samsung.mk b/target/linux/ramips/rt3883/profiles/samsung.mk
new file mode 100644
index 0000000..18f60d4
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/samsung.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/CYSWR1100
+ NAME:=Samsung CY-SWR1100
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+
+define Profile/CYSWR1100/Description
+ Package set compatible with the Samsung CY-SWR1100 board.
+endef
+$(eval $(call Profile,CYSWR1100))
diff --git a/target/linux/ramips/rt3883/profiles/trendnet.mk b/target/linux/ramips/rt3883/profiles/trendnet.mk
new file mode 100644
index 0000000..5a055ae
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/trendnet.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TEW691GR
+ NAME:=TRENDnet TEW-691GR
+ PACKAGES:=swconfig
+endef
+
+define Profile/TEW691GR/Description
+ Package set compatible with the TRENDnet TEW-691GR board.
+endef
+$(eval $(call Profile,TEW691GR))
+
+
+define Profile/TEW692GR
+ NAME:=TRENDnet TEW-692GR
+ PACKAGES:=swconfig
+endef
+
+define Profile/TEW692GR/Description
+ Package set compatible with the TRENDnet TEW-692GR board.
+endef
+$(eval $(call Profile,TEW692GR))