aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-09-21 17:58:33 +0200
committerGitHub <noreply@github.com>2016-09-21 17:58:33 +0200
commitb136759a170bd7348eaebaf0197bf61cf80bf6f3 (patch)
treef2df00f23d88eb05454540f56ca5731ce8e1e9ae /package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
parent5ce38c486c525b28d9784f83e839537aa0149123 (diff)
parent6faa54673d51f5da2a777b6c20f261f49544b627 (diff)
downloadmaster-187ad058-b136759a170bd7348eaebaf0197bf61cf80bf6f3.tar.gz
master-187ad058-b136759a170bd7348eaebaf0197bf61cf80bf6f3.tar.bz2
master-187ad058-b136759a170bd7348eaebaf0197bf61cf80bf6f3.zip
Merge pull request #90 from wigyori/master
xtables-addons update, drop sched_getcpu from perf
Diffstat (limited to 'package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch')
-rw-r--r--package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
index 6a7a099fcc..775ccf657c 100644
--- a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
+++ b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
@@ -1,11 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
+@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
if test -n "$kbuilddir"; then
AC_MSG_CHECKING([kernel version that we will build against])
-- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
-+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
- save_IFS=$IFS;
- IFS='.';
- set x $krel;
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
+ save_IFS="$IFS"
+ IFS='.'
+ set x $krel