aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-09-21 17:58:33 +0200
committerGitHub <noreply@github.com>2016-09-21 17:58:33 +0200
commitb136759a170bd7348eaebaf0197bf61cf80bf6f3 (patch)
treef2df00f23d88eb05454540f56ca5731ce8e1e9ae
parent5ce38c486c525b28d9784f83e839537aa0149123 (diff)
parent6faa54673d51f5da2a777b6c20f261f49544b627 (diff)
downloadmaster-187ad058-b136759a170bd7348eaebaf0197bf61cf80bf6f3.tar.gz
master-187ad058-b136759a170bd7348eaebaf0197bf61cf80bf6f3.tar.bz2
master-187ad058-b136759a170bd7348eaebaf0197bf61cf80bf6f3.zip
Merge pull request #90 from wigyori/master
xtables-addons update, drop sched_getcpu from perf
-rw-r--r--package/devel/perf/Makefile1
-rw-r--r--package/devel/perf/musl-compat.h17
-rw-r--r--package/devel/strace/Makefile6
-rw-r--r--package/network/utils/xtables-addons/Makefile7
-rw-r--r--package/network/utils/xtables-addons/patches/001-build-fix-configure-compatiblity-with-POSIX-shells.patch51
-rw-r--r--package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch12
6 files changed, 13 insertions, 81 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index ec4e3c295a..0ec2bba3e2 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -49,6 +49,7 @@ MAKE_FLAGS = \
NO_LIBNUMA=1 \
NO_GTK2=1 \
NO_LIBAUDIT=1 \
+ NO_LIBCRYPTO=1 \
CROSS_COMPILE="$(TARGET_CROSS)" \
CC="$(TARGET_CC)" \
LD="$(TARGET_CROSS)ld" \
diff --git a/package/devel/perf/musl-compat.h b/package/devel/perf/musl-compat.h
index 8ce97bea88..83aa00a7c8 100644
--- a/package/devel/perf/musl-compat.h
+++ b/package/devel/perf/musl-compat.h
@@ -7,7 +7,6 @@
#include <asm/unistd.h>
#include <unistd.h>
#include <stdio.h>
-#include <sched.h>
#undef _IOWR
#undef _IOR
@@ -40,21 +39,5 @@ static inline long sysconf_wrap(int name)
#define sysconf(_n) sysconf_wrap(_n)
-static inline int compat_sched_getcpu(void)
-{
-#ifdef __NR_getcpu
- unsigned int val;
-
- if (syscall(__NR_getcpu, &val))
- return -1;
-
- return val;
-#else
- return -1;
-#endif
-}
-
-#define sched_getcpu compat_sched_getcpu
-
#endif
#endif
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index 6d9a7be534..688f40308d 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,9 +10,9 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=strace
-PKG_VERSION:=4.12
+PKG_VERSION:=4.13
PKG_RELEASE:=1
-PKG_MD5SUM:=efb8611fc332e71ec419c53f59faa93e
+PKG_MD5SUM:=4b78c7febdd24c79d5147824d1a080a3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
diff --git a/package/network/utils/xtables-addons/Makefile b/package/network/utils/xtables-addons/Makefile
index da8058ebab..280b4b889d 100644
--- a/package/network/utils/xtables-addons/Makefile
+++ b/package/network/utils/xtables-addons/Makefile
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons
-PKG_VERSION:=2.10
+PKG_VERSION:=2.11
PKG_RELEASE:=1
-PKG_MD5SUM:=727bf0dd4a3d9c65724267bd0d5d80b0
+PKG_MD5SUM:=9f3123295db81a9d1bc08dabf075d0d6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/xtables-addons
@@ -39,7 +39,6 @@ endef
CONFIGURE_ARGS+= \
--with-kbuild="$(LINUX_DIR)" \
- --with-xtables="$(STAGING_DIR)/usr" \
--with-xtlibdir="/usr/lib/iptables" \
define Build/Compile
@@ -146,7 +145,7 @@ $(eval $(call BuildTemplate,lscan,lscan,xt_lscan,xt_lscan,))
$(eval $(call BuildTemplate,lua,Lua PacketScript,xt_LUA,LUA/xt_LUA,+kmod-ipt-conntrack-extra))
$(eval $(call BuildTemplate,psd,psd,xt_psd,xt_psd,))
$(eval $(call BuildTemplate,quota2,quota2,xt_quota2,xt_quota2,))
-$(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,+kmod-ipt-compat-xtables))
+$(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,+kmod-ipt-compat-xtables +kmod-crypto-hash))
$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,+kmod-ipt-compat-xtables))
$(eval $(call BuildPackage,iptaccount))
diff --git a/package/network/utils/xtables-addons/patches/001-build-fix-configure-compatiblity-with-POSIX-shells.patch b/package/network/utils/xtables-addons/patches/001-build-fix-configure-compatiblity-with-POSIX-shells.patch
deleted file mode 100644
index e0b11b5459..0000000000
--- a/package/network/utils/xtables-addons/patches/001-build-fix-configure-compatiblity-with-POSIX-shells.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From f07a0a5cb8b3c5e1aee8b30c7fa21ccfbf24a95a Mon Sep 17 00:00:00 2001
-Message-Id: <f07a0a5cb8b3c5e1aee8b30c7fa21ccfbf24a95a.1459880505.git.mschiffer@universe-factory.net>
-From: Matthias Schiffer <mschiffer@universe-factory.net>
-Date: Fri, 1 Apr 2016 22:24:00 +0200
-Subject: [PATCH] build: fix configure compatiblity with POSIX shells
-
-The kernel version detection code uses some bashisms, which makes the build
-fail on Debian systems where /bin/sh links to dash. Replace with POSIX-
-conforming commands at the cost of requiring awk.
----
- configure.ac | 24 +++++++++---------------
- 1 file changed, 9 insertions(+), 15 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 82a1355..5a5ea57 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -44,21 +44,15 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
-
- if test -n "$kbuilddir"; then
- AC_MSG_CHECKING([kernel version that we will build against])
-- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
-- kmajor="${krel%%[[^0-9]]*}";
-- kmajor="$(($kmajor+0))";
-- krel="${krel:${#kmajor}}";
-- krel="${krel#.}";
-- kminor="${krel%%[[^0-9]]*}";
-- kminor="$(($kminor+0))";
-- krel="${krel:${#kminor}}";
-- krel="${krel#.}";
-- kmicro="${krel%%[[^0-9]]*}";
-- kmicro="$(($kmicro+0))";
-- krel="${krel:${#kmicro}}";
-- krel="${krel#.}";
-- kstable="${krel%%[[^0-9]]*}";
-- kstable="$(($kstable+0))";
-+ krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
-+ save_IFS=$IFS;
-+ IFS='.';
-+ set x $krel;
-+ IFS=$save_IFS;
-+ kmajor="$(($2+0))";
-+ kminor="$(($3+0))";
-+ kmicro="$(($4+0))";
-+ kstable="$(($5+0))";
- if test -z "$kmajor" -o -z "$kminor" -o -z "$kmicro"; then
- echo "WARNING: Version detection did not succeed. Continue at own luck.";
- else
---
-2.8.0
-
diff --git a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
index 6a7a099fcc..775ccf657c 100644
--- a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
+++ b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
@@ -1,11 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
+@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
if test -n "$kbuilddir"; then
AC_MSG_CHECKING([kernel version that we will build against])
-- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
-+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
- save_IFS=$IFS;
- IFS='.';
- set x $krel;
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
+ save_IFS="$IFS"
+ IFS='.'
+ set x $krel