aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch')
-rw-r--r--package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
index 6a7a099fcc..775ccf657c 100644
--- a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
+++ b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
@@ -1,11 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
+@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
if test -n "$kbuilddir"; then
AC_MSG_CHECKING([kernel version that we will build against])
-- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
-+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
- save_IFS=$IFS;
- IFS='.';
- set x $krel;
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
+ save_IFS="$IFS"
+ IFS='.'
+ set x $krel