aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:14 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:14 +0000
commite0d21348b5527b507648cd87898501eade36a94f (patch)
tree71fc01237b81f38d68223aa8defefb528a4213a8 /include/image.mk
parent7628642fc4c839fd11f13afa735e614586af2208 (diff)
downloadmaster-187ad058-e0d21348b5527b507648cd87898501eade36a94f.tar.gz
master-187ad058-e0d21348b5527b507648cd87898501eade36a94f.tar.bz2
master-187ad058-e0d21348b5527b507648cd87898501eade36a94f.zip
image.mk: replace all Build/netgear-chk with a generic implementation
Instead of letting each target define it themselves, create on in include/image.mk and let the targets use it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46596 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 979db5f554..583bc66157 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -299,6 +299,15 @@ define Build/uImage
@mv $@.new $@
endef
+define Build/netgear-chk
+ $(STAGING_DIR_HOST)/bin/mkchkimg \
+ -o $@.new \
+ -k $@ \
+ -b $(NETGEAR_BOARD_ID) \
+ -r $(NETGEAR_REGION)
+ mv $@.new $@
+endef
+
define Build/lzma
$(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
@mv $@.new $@