aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:14 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:14 +0000
commite0d21348b5527b507648cd87898501eade36a94f (patch)
tree71fc01237b81f38d68223aa8defefb528a4213a8
parent7628642fc4c839fd11f13afa735e614586af2208 (diff)
downloadmaster-187ad058-e0d21348b5527b507648cd87898501eade36a94f.tar.gz
master-187ad058-e0d21348b5527b507648cd87898501eade36a94f.tar.bz2
master-187ad058-e0d21348b5527b507648cd87898501eade36a94f.zip
image.mk: replace all Build/netgear-chk with a generic implementation
Instead of letting each target define it themselves, create on in include/image.mk and let the targets use it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46596 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/image.mk9
-rw-r--r--target/linux/bcm53xx/image/Makefile6
-rw-r--r--target/linux/brcm47xx/image/Makefile9
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile6
4 files changed, 9 insertions, 21 deletions
diff --git a/include/image.mk b/include/image.mk
index 979db5f554..583bc66157 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -299,6 +299,15 @@ define Build/uImage
@mv $@.new $@
endef
+define Build/netgear-chk
+ $(STAGING_DIR_HOST)/bin/mkchkimg \
+ -o $@.new \
+ -k $@ \
+ -b $(NETGEAR_BOARD_ID) \
+ -r $(NETGEAR_REGION)
+ mv $@.new $@
+endef
+
define Build/lzma
$(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
@mv $@.new $@
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fdb2c05e3a..7aa9fc2a3a 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -60,12 +60,6 @@ define Build/asus-trx
mv $@.new $@
endef
-define Build/netgear-chk
- $(STAGING_DIR_HOST)/bin/mkchkimg \
- -o $@.new -k $@ -b $(NETGEAR_BOARD_ID) -r $(NETGEAR_REGION)
- mv $@.new $@
-endef
-
DEVICE_VARS += DT PRODUCTID NETGEAR_BOARD_ID NETGEAR_REGION
define Device/Default
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index b2516a994c..7405d0f28d 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -126,15 +126,6 @@ define Build/linksys-bin
mv $@.new $@
endef
-define Build/netgear-chk
- $(STAGING_DIR_HOST)/bin/mkchkimg \
- -o $@.new \
- -k $@ \
- -b $(NETGEAR_BOARD_ID) \
- -r $(NETGEAR_REGION)
- mv $@.new $@
-endef
-
#################################################
# Devices
#################################################
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 235b60c404..c5c982f5e1 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -136,12 +136,6 @@ define Build/cfe-spw303v-bin
$(CFE_EXTRAS)
endef
-define Build/netgear-chk
- $(STAGING_DIR_HOST)/bin/mkchkimg -o $@.netgear -k $@ \
- -b $(NETGEAR_BOARD_ID) -r $(NETGEAR_REGION)
- mv $@.netgear $@
-endef
-
define Build/spw303v-bin
$(STAGING_DIR_HOST)/bin/spw303v -i $@ -o $@.spw303v
mv $@.spw303v $@