aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 979db5f554..583bc66157 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -299,6 +299,15 @@ define Build/uImage
@mv $@.new $@
endef
+define Build/netgear-chk
+ $(STAGING_DIR_HOST)/bin/mkchkimg \
+ -o $@.new \
+ -k $@ \
+ -b $(NETGEAR_BOARD_ID) \
+ -r $(NETGEAR_REGION)
+ mv $@.new $@
+endef
+
define Build/lzma
$(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
@mv $@.new $@