diff options
author | gdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4> | 2014-11-04 09:40:51 +0000 |
---|---|---|
committer | gdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4> | 2014-11-04 09:40:51 +0000 |
commit | efb5332373ccaa36b2d2e465b3bceb2b7f4b7655 (patch) | |
tree | 58e3a6adbd48cfb42d6d4dfe4ae36d362b00fc44 /os/rt/ports/SIMIA32 | |
parent | 8b0021db47f08c7523609987d87be34176bbe9d4 (diff) | |
download | ChibiOS-efb5332373ccaa36b2d2e465b3bceb2b7f4b7655.tar.gz ChibiOS-efb5332373ccaa36b2d2e465b3bceb2b7f4b7655.tar.bz2 ChibiOS-efb5332373ccaa36b2d2e465b3bceb2b7f4b7655.zip |
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@7473 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/rt/ports/SIMIA32')
-rw-r--r-- | os/rt/ports/SIMIA32/chcore.h | 4 | ||||
-rw-r--r-- | os/rt/ports/SIMIA32/compilers/GCC/port.mk | 5 |
2 files changed, 5 insertions, 4 deletions
diff --git a/os/rt/ports/SIMIA32/chcore.h b/os/rt/ports/SIMIA32/chcore.h index 70e16199a..9c8cd2587 100644 --- a/os/rt/ports/SIMIA32/chcore.h +++ b/os/rt/ports/SIMIA32/chcore.h @@ -147,7 +147,7 @@ struct port_intctx { * @p port_intctx structure representing the stack pointer
* at context switch time.
*/
-struct port_context {
+struct context {
struct intctx volatile *esp;
};
@@ -230,7 +230,7 @@ struct port_context { #ifdef __cplusplus
extern "C" {
#endif
- __attribute__((fastcall)) void port_switch(Thread *ntp, Thread *otp);
+ __attribute__((fastcall)) void port_switch(thread_t *ntp, thread_t *otp);
__attribute__((cdecl, noreturn)) void _port_thread_start(msg_t (*pf)(void *),
void *p);
void _sim_check_for_interrupts(void);
diff --git a/os/rt/ports/SIMIA32/compilers/GCC/port.mk b/os/rt/ports/SIMIA32/compilers/GCC/port.mk index 8f053abc4..0d5f0903d 100644 --- a/os/rt/ports/SIMIA32/compilers/GCC/port.mk +++ b/os/rt/ports/SIMIA32/compilers/GCC/port.mk @@ -1,6 +1,7 @@ # List of the ChibiOS/RT SIMIA32 port files.
-PORTSRC = ${CHIBIOS}/os/ports/GCC/SIMIA32/chcore.c
+PORTSRC = ${CHIBIOS}/os/rt/ports/SIMIA32/chcore.c
PORTASM =
-PORTINC = ${CHIBIOS}/os/ports/GCC/SIMIA32
+PORTINC = ${CHIBIOS}/os/rt/ports/SIMIA32/compilers/GCC \
+ ${CHIBIOS}/os/rt/ports/SIMIA32
|