aboutsummaryrefslogtreecommitdiffstats
path: root/os/rt/ports/SIMIA32
diff options
context:
space:
mode:
Diffstat (limited to 'os/rt/ports/SIMIA32')
-rw-r--r--os/rt/ports/SIMIA32/chcore.h4
-rw-r--r--os/rt/ports/SIMIA32/compilers/GCC/port.mk5
2 files changed, 5 insertions, 4 deletions
diff --git a/os/rt/ports/SIMIA32/chcore.h b/os/rt/ports/SIMIA32/chcore.h
index 70e16199a..9c8cd2587 100644
--- a/os/rt/ports/SIMIA32/chcore.h
+++ b/os/rt/ports/SIMIA32/chcore.h
@@ -147,7 +147,7 @@ struct port_intctx {
* @p port_intctx structure representing the stack pointer
* at context switch time.
*/
-struct port_context {
+struct context {
struct intctx volatile *esp;
};
@@ -230,7 +230,7 @@ struct port_context {
#ifdef __cplusplus
extern "C" {
#endif
- __attribute__((fastcall)) void port_switch(Thread *ntp, Thread *otp);
+ __attribute__((fastcall)) void port_switch(thread_t *ntp, thread_t *otp);
__attribute__((cdecl, noreturn)) void _port_thread_start(msg_t (*pf)(void *),
void *p);
void _sim_check_for_interrupts(void);
diff --git a/os/rt/ports/SIMIA32/compilers/GCC/port.mk b/os/rt/ports/SIMIA32/compilers/GCC/port.mk
index 8f053abc4..0d5f0903d 100644
--- a/os/rt/ports/SIMIA32/compilers/GCC/port.mk
+++ b/os/rt/ports/SIMIA32/compilers/GCC/port.mk
@@ -1,6 +1,7 @@
# List of the ChibiOS/RT SIMIA32 port files.
-PORTSRC = ${CHIBIOS}/os/ports/GCC/SIMIA32/chcore.c
+PORTSRC = ${CHIBIOS}/os/rt/ports/SIMIA32/chcore.c
PORTASM =
-PORTINC = ${CHIBIOS}/os/ports/GCC/SIMIA32
+PORTINC = ${CHIBIOS}/os/rt/ports/SIMIA32/compilers/GCC \
+ ${CHIBIOS}/os/rt/ports/SIMIA32