aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 12:08:42 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 12:08:42 +0000
commitf4781e1591b26afb71bd24a772c4b7aa8cff54a5 (patch)
tree9cc5700b7eeec11fa59a6590f58ba25b02d3b50c /target/linux/mvebu
parentb1c82b87fc31b4b6f0acae9d7239465712464954 (diff)
downloadmaster-187ad058-f4781e1591b26afb71bd24a772c4b7aa8cff54a5.tar.gz
master-187ad058-f4781e1591b26afb71bd24a772c4b7aa8cff54a5.tar.bz2
master-187ad058-f4781e1591b26afb71bd24a772c4b7aa8cff54a5.zip
mvebu: stop legacy image generation
If you can't find the firmware for you board, send proper patches. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45413 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 191dc27a00..269ad19991 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -22,8 +22,6 @@ define Image/Build/DTB
$(call Image/BuildKernel/MkuImage, \
none, $(LOADADDR), $(LOADADDR), \
$(KDIR)/zImage$(2)-$(1), $(KDIR)/uImage$(2)-$(1))
-# The next line will be dropped, migrate your board to use a single firmware file
- cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
endef
# $(1): Profile Name
@@ -50,8 +48,6 @@ define NANDProfile
define Image/Build/Profile/$(1)/squashfs
$(call Image/Build/UbinizeImage,$(2),,squashfs, -p $(3) -m $(4) $(if $(5),-s $(5)) $(if $(6),-O $(6)))
-# The next line will be dropped, migrate your board to use a single firmware file
- cp $(KDIR)/$$(IMG_PREFIX)-$(2)-squashfs-ubinized.bin $(BIN_DIR)
endef
PROFILES_LIST += $(1)
@@ -179,8 +175,6 @@ endef
define Image/Build
$(call Image/Build/$(1))
-# The next line will be dropped, migrate your board to use a single firmware file
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
$(call Image/Build/Profile/$(PROFILE)/BuildSysupgrade,$(1))
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/Build/Profile/$(PROFILE)/Initramfs)