aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 12:06:56 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 12:06:56 +0000
commitb1c82b87fc31b4b6f0acae9d7239465712464954 (patch)
treeb7573a9cb5ecc52681455fe45dfecf26c87cda17 /target/linux/mvebu
parent45bd4eaea37fd226d065b5388a41748a0924fa94 (diff)
downloadmaster-187ad058-b1c82b87fc31b4b6f0acae9d7239465712464954.tar.gz
master-187ad058-b1c82b87fc31b4b6f0acae9d7239465712464954.tar.bz2
master-187ad058-b1c82b87fc31b4b6f0acae9d7239465712464954.zip
mvebu: generate a single firmware for the 385-db-ap
This has been done without having a board, but should work. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45412 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 443110113c..191dc27a00 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -154,6 +154,15 @@ define Image/Build/Profile/Mamba/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
+define Image/Build/Profile/385-DB-AP/squashfs
+ $(call Image/Build/UbinizeImage,armada-385-db-ap,,squashfs, -p 256KiB -m 4096)
+ ( \
+ dd if=$(KDIR)/uImage-armada-385-db-ap bs=8M conv=sync; \
+ dd if=$(KDIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-ubinized.bin \
+ bs=4096 conv=sync; \
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-factory.img
+endef
+
# The Default profile should build everything
$(eval $(call MultiProfile,Default,$(PROFILES_LIST)))