aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 12:15:40 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 12:15:40 +0000
commit4c0754e53349878e5551713be464bb42cb99a59f (patch)
tree6252eec9a81fb4f4d3884ca7451a6a4ef8f2c251 /target/linux/mvebu
parentf4781e1591b26afb71bd24a772c4b7aa8cff54a5 (diff)
downloadmaster-187ad058-4c0754e53349878e5551713be464bb42cb99a59f.tar.gz
master-187ad058-4c0754e53349878e5551713be464bb42cb99a59f.tar.bz2
master-187ad058-4c0754e53349878e5551713be464bb42cb99a59f.zip
mvebu: add comments to image generation
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45414 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 269ad19991..0d75e30eda 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -141,6 +141,11 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
# Boards with small NOR, where UBI doesn't make sense
$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
+###
+### Linksys
+###
+
+# Mamba: Linksys WRT1900AC
define Image/Build/Profile/Mamba/squashfs
$(call Image/Build/UbinizeImage,armada-xp-linksys-mamba,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
( \
@@ -150,6 +155,11 @@ define Image/Build/Profile/Mamba/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
+###
+### Marvell
+###
+
+# Marvell Armada 385 Access Point Development board (DB-88F6820-AP)
define Image/Build/Profile/385-DB-AP/squashfs
$(call Image/Build/UbinizeImage,armada-385-db-ap,,squashfs, -p 256KiB -m 4096)
( \
@@ -159,6 +169,7 @@ define Image/Build/Profile/385-DB-AP/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-factory.img
endef
+
# The Default profile should build everything
$(eval $(call MultiProfile,Default,$(PROFILES_LIST)))