aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
commit58095e3bebf2dfce842149693ef07015844d3bbd (patch)
tree7861ac97ee68e4dba8c59d7775efdd0adfe4612c /target/linux/linux-2.4/Makefile
parent0e742821a57a67febacd2f28d06fab276d6fcf0e (diff)
downloadmaster-187ad058-58095e3bebf2dfce842149693ef07015844d3bbd.tar.gz
master-187ad058-58095e3bebf2dfce842149693ef07015844d3bbd.tar.bz2
master-187ad058-58095e3bebf2dfce842149693ef07015844d3bbd.zip
fix kernel package and kernel modules dependency on it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2492 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/linux-2.4/Makefile')
-rw-r--r--target/linux/linux-2.4/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index d487446209..39828963eb 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -426,8 +426,7 @@ $(TARGET_MODULES_DIR):
$(KERNEL_IPKG):
rm -rf $(KERNEL_IDIR)
mkdir -p $(KERNEL_IDIR)/etc
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
- echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
if [ -f ./config/$(BOARD).modules ]; then \
cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
fi