aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
commit58095e3bebf2dfce842149693ef07015844d3bbd (patch)
tree7861ac97ee68e4dba8c59d7775efdd0adfe4612c
parent0e742821a57a67febacd2f28d06fab276d6fcf0e (diff)
downloadmaster-187ad058-58095e3bebf2dfce842149693ef07015844d3bbd.tar.gz
master-187ad058-58095e3bebf2dfce842149693ef07015844d3bbd.tar.bz2
master-187ad058-58095e3bebf2dfce842149693ef07015844d3bbd.zip
fix kernel package and kernel modules dependency on it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2492 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/control/kernel.control1
-rw-r--r--target/linux/linux-2.4/Makefile3
-rw-r--r--target/linux/linux-2.6/Makefile3
-rw-r--r--target/linux/rules.mk6
4 files changed, 4 insertions, 9 deletions
diff --git a/target/linux/control/kernel.control b/target/linux/control/kernel.control
index 32e6fdc313..5432d21a0f 100644
--- a/target/linux/control/kernel.control
+++ b/target/linux/control/kernel.control
@@ -1,3 +1,4 @@
+Package: kernel
Priority: optional
Section: sys
Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index d487446209..39828963eb 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -426,8 +426,7 @@ $(TARGET_MODULES_DIR):
$(KERNEL_IPKG):
rm -rf $(KERNEL_IDIR)
mkdir -p $(KERNEL_IDIR)/etc
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
- echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
if [ -f ./config/$(BOARD).modules ]; then \
cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
fi
diff --git a/target/linux/linux-2.6/Makefile b/target/linux/linux-2.6/Makefile
index ce49930470..212a4a76ab 100644
--- a/target/linux/linux-2.6/Makefile
+++ b/target/linux/linux-2.6/Makefile
@@ -444,8 +444,7 @@ $(TARGET_MODULES_DIR):
$(KERNEL_IPKG):
rm -rf $(KERNEL_IDIR)
mkdir -p $(KERNEL_IDIR)/etc
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
- echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
if [ -f ./config/$(BOARD).modules ]; then \
cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
fi
diff --git a/target/linux/rules.mk b/target/linux/rules.mk
index be151ea10f..8871fa442e 100644
--- a/target/linux/rules.mk
+++ b/target/linux/rules.mk
@@ -17,11 +17,7 @@ else
KDEPEND_$(1):=$($(4))
endif
-ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
-else
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
-endif
+IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)) $(foreach pkg,$(5),", $(pkg)")
PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
I_$(1) := $(PKG_BUILD_DIR)/ipkg/$(2)