aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-21 21:24:44 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-21 21:24:44 +0000
commiteed1eb06f391cc8a600e58482e12b57588931542 (patch)
treedc0dedd454d4a031a2101a40128aee062ba81a9b /target/linux/brcm2708
parentfbdb472f4554ff1cf53cc8d35c2f95beb6ed6225 (diff)
downloadmaster-187ad058-eed1eb06f391cc8a600e58482e12b57588931542.tar.gz
master-187ad058-eed1eb06f391cc8a600e58482e12b57588931542.tar.bz2
master-187ad058-eed1eb06f391cc8a600e58482e12b57588931542.zip
brcm2708: simplify gzip image generation
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47558 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/image/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index cf263bdf01..ecf6f71835 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -11,16 +11,6 @@ include $(INCLUDE_DIR)/host.mk
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
- define Image/gzip
- gzip -9n -c $(1) > $(1).gz
- mv $(1).gz $(BIN_DIR)
- endef
-else
- define Image/gzip
- endef
-endif
-
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -49,7 +39,7 @@ endef
define Build/sdcard-img
./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
- $(call Image/gzip,$@)
+ $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
endef
### Device macros ###