aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/brcm2708/image/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index cf263bdf01..ecf6f71835 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -11,16 +11,6 @@ include $(INCLUDE_DIR)/host.mk
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
- define Image/gzip
- gzip -9n -c $(1) > $(1).gz
- mv $(1).gz $(BIN_DIR)
- endef
-else
- define Image/gzip
- endef
-endif
-
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -49,7 +39,7 @@ endef
define Build/sdcard-img
./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
- $(call Image/gzip,$@)
+ $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
endef
### Device macros ###