aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-03-16 12:32:22 +0000
committerNicolas Thill <nico@openwrt.org>2015-03-16 12:32:22 +0000
commitd951b2beb11b3c74babeea15b628d583e10e6fff (patch)
tree6aa81f7d1c1dba2e110a17089da1ee67bf344167 /package
parent7105a54bcb1ec09bd71ed530ef16ac39a08c06c3 (diff)
downloadmaster-187ad058-d951b2beb11b3c74babeea15b628d583e10e6fff.tar.gz
master-187ad058-d951b2beb11b3c74babeea15b628d583e10e6fff.tar.bz2
master-187ad058-d951b2beb11b3c74babeea15b628d583e10e6fff.zip
packages: more (e)glibc fixes after r44701
_GNU_SOURCE has been declared "deprecated" in favor of _DEFAULT_SOURCE in glibc Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rw-r--r--package/utils/ugps/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 7c0989de1a..f4de987e65 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -107,6 +107,10 @@ define Package/uhttpd/conffiles
/etc/uhttpd.key
endef
+ifneq ($(CONFIG_USE_GLIBC),)
+ TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
TARGET_LDFLAGS += -lcrypt
CMAKE_OPTIONS = -DTLS_SUPPORT=on
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index c1bc7cdd01..3662125c3a 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -32,6 +32,10 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+ifneq ($(CONFIG_USE_GLIBC),)
+ TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
define Package/ugps/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/