aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/ugps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/ugps/Makefile')
-rw-r--r--package/utils/ugps/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index c1bc7cdd01..3662125c3a 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -32,6 +32,10 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+ifneq ($(CONFIG_USE_GLIBC),)
+ TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
define Package/ugps/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/