aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-03-16 12:25:06 +0000
committerNicolas Thill <nico@openwrt.org>2015-03-16 12:25:06 +0000
commit7105a54bcb1ec09bd71ed530ef16ac39a08c06c3 (patch)
treed2268e094f43ad915138f40df3e8501203f45bd1 /package/system
parent36da43e2deb597cecf6ed8ef8f2fb042cde7c83e (diff)
downloadmaster-187ad058-7105a54bcb1ec09bd71ed530ef16ac39a08c06c3.tar.gz
master-187ad058-7105a54bcb1ec09bd71ed530ef16ac39a08c06c3.tar.bz2
master-187ad058-7105a54bcb1ec09bd71ed530ef16ac39a08c06c3.zip
packages: some (e)glibc fixes after r44701
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44842 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system')
-rw-r--r--package/system/fstools/Makefile4
-rw-r--r--package/system/procd/Makefile4
-rw-r--r--package/system/ubox/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 054be0f43f..9040fd9417 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -30,13 +30,13 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
define Package/fstools
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubox +USE_EGLIBC:librt +NAND_SUPPORT:ubi-utils
+ DEPENDS:=+ubox +USE_GLIBC:librt +NAND_SUPPORT:ubi-utils
TITLE:=OpenWrt filesystem tools
MENU:=1
endef
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 02520606e8..6f9e6f8562 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -27,12 +27,12 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
+ DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_GLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
TITLE:=OpenWrt system process manager
endef
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index b58eb16b4d..5a51dc08dc 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -20,12 +20,12 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
define Package/ubox
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_EGLIBC:librt
+ DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_GLIBC:librt
TITLE:=OpenWrt system helper toolbox
endef