aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/am33x-cm3
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-03-30 09:15:25 +0000
committerJohn Crispin <blogic@openwrt.org>2014-03-30 09:15:25 +0000
commitbbff25f740a1c4c9412fc0e7381eba266b261244 (patch)
tree6c2b4bcbc2e012ece0d1ae80e6adc52fb74fc72b /package/firmware/am33x-cm3
parent5e3b47eefcbb1bcf7c89df345d6197052960ed5f (diff)
downloadmaster-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.tar.gz
master-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.tar.bz2
master-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.zip
firmware: create a new folder for holfing firmware blobs
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware/am33x-cm3')
-rw-r--r--package/firmware/am33x-cm3/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/package/firmware/am33x-cm3/Makefile b/package/firmware/am33x-cm3/Makefile
new file mode 100644
index 0000000000..bd7e2ae536
--- /dev/null
+++ b/package/firmware/am33x-cm3/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=am33x-cm3
+PKG_VERSION:=20130304
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=git://arago-project.org/git/projects/am33x-cm3.git
+PKG_SOURCE_VERSION:=32cf44e25b5828b87af6dceebc3a49fed5d858ac
+PKG_MD5SUM:=40a6b7edae5e5cfff99bebde2bf20b97
+
+PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/am33x-cm3
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=http://arago-project.org/git/projects/?p=am33x-cm3.git
+ TITLE:=TI AM335x PM firmware
+ DEPENDS:=@TARGET_omap
+endef
+
+define Build/Compile
+ $(MAKE) CROSS_COMPILE=$(TARGET_CROSS) -C $(PKG_BUILD_DIR)
+endef
+
+define Package/am33x-cm3/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(CP) $(PKG_BUILD_DIR)/bin/am335x-pm-firmware.bin $(1)/lib/firmware
+endef
+
+$(eval $(call BuildPackage,am33x-cm3))