aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:45 +0000
commitc52c5e1d1230d7a190baad89fecd8b68540310bb (patch)
tree665b53a44b60800a905054fee58bffb11af86358 /include/package-ipkg.mk
parenta7a8f77c08d5cb7ed1be71e0eb85a2f3d137aca9 (diff)
downloadmaster-187ad058-c52c5e1d1230d7a190baad89fecd8b68540310bb.tar.gz
master-187ad058-c52c5e1d1230d7a190baad89fecd8b68540310bb.tar.bz2
master-187ad058-c52c5e1d1230d7a190baad89fecd8b68540310bb.zip
kernel: use /bin/sh instead of bash to speed up processing of many kmod-* packages
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43022 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index e3bfe6bf7a..b8c8cd6f99 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/feeds.mk
# invoke ipkg-build with some default options
IPKG_BUILD:= \
- ipkg-build -c -o 0 -g 0
+ $(STAGING_DIR_HOST)/bin/ipkg-build -c -o 0 -g 0
IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
@@ -185,7 +185,7 @@ $(_endef)
(cd $$(IDIR_$(1))/CONTROL; \
( \
echo "$$$$CONTROL"; \
- echo -n "Description: "; echo "$$$$DESCRIPTION" | sed -e 's,^[[:space:]]*, ,g'; \
+ printf "Description: "; echo "$$$$DESCRIPTION" | sed -e 's,^[[:space:]]*, ,g'; \
) > control; \
chmod 644 control; \
( \