aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-ipkg.mk4
-rw-r--r--package/kernel/linux/Makefile2
2 files changed, 4 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index e3bfe6bf7a..b8c8cd6f99 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/feeds.mk
# invoke ipkg-build with some default options
IPKG_BUILD:= \
- ipkg-build -c -o 0 -g 0
+ $(STAGING_DIR_HOST)/bin/ipkg-build -c -o 0 -g 0
IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
@@ -185,7 +185,7 @@ $(_endef)
(cd $$(IDIR_$(1))/CONTROL; \
( \
echo "$$$$CONTROL"; \
- echo -n "Description: "; echo "$$$$DESCRIPTION" | sed -e 's,^[[:space:]]*, ,g'; \
+ printf "Description: "; echo "$$$$DESCRIPTION" | sed -e 's,^[[:space:]]*, ,g'; \
) > control; \
chmod 644 control; \
( \
diff --git a/package/kernel/linux/Makefile b/package/kernel/linux/Makefile
index e10e99c51e..6fb6851b92 100644
--- a/package/kernel/linux/Makefile
+++ b/package/kernel/linux/Makefile
@@ -17,6 +17,8 @@ SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
+export SHELL:=/bin/sh
+
include $(INCLUDE_DIR)/package.mk
STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))