aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-26 12:42:48 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-26 12:42:48 +0000
commit9e4ac0159319a980a2d3c87c1cccbbc8a7c48fcd (patch)
tree74e7bac4d7ec58a90710e273c32285d0f5463694 /include/package-ipkg.mk
parent03d2c2ee54f8bcb8b022a6f7c648178f31441d6f (diff)
downloadmaster-187ad058-9e4ac0159319a980a2d3c87c1cccbbc8a7c48fcd.tar.gz
master-187ad058-9e4ac0159319a980a2d3c87c1cccbbc8a7c48fcd.tar.bz2
master-187ad058-9e4ac0159319a980a2d3c87c1cccbbc8a7c48fcd.zip
move rule for $(STAGING_DIR)/etc/ipkg.conf out of BuildIPKG so that it's defined only once
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8491 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index c67ee4b8ae..cc9a780147 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -71,11 +71,6 @@ ifeq ($(DUMP),)
$$(INFO_$(1)): $$(IPKG_$(1))
$(IPKG) install $$(IPKG_$(1))
- $(STAGING_DIR)/etc/ipkg.conf:
- mkdir -p $(STAGING_DIR)/etc
- echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
- echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
-
$(1)-clean:
rm -f $(PACKAGE_DIR)/$(1)_*
@@ -88,4 +83,10 @@ ifeq ($(DUMP),)
$$(eval $$(call Build/DefaultTargets,$(1)))
endef
+
+ $(STAGING_DIR)/etc/ipkg.conf:
+ mkdir -p $(STAGING_DIR)/etc
+ echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
+ echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
+
endif