aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-ipkg.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index c67ee4b8ae..cc9a780147 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -71,11 +71,6 @@ ifeq ($(DUMP),)
$$(INFO_$(1)): $$(IPKG_$(1))
$(IPKG) install $$(IPKG_$(1))
- $(STAGING_DIR)/etc/ipkg.conf:
- mkdir -p $(STAGING_DIR)/etc
- echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
- echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
-
$(1)-clean:
rm -f $(PACKAGE_DIR)/$(1)_*
@@ -88,4 +83,10 @@ ifeq ($(DUMP),)
$$(eval $$(call Build/DefaultTargets,$(1)))
endef
+
+ $(STAGING_DIR)/etc/ipkg.conf:
+ mkdir -p $(STAGING_DIR)/etc
+ echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
+ echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
+
endif