aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@citrix.com>2012-07-24 09:35:44 +0100
committerRoger Pau Monne <roger.pau@citrix.com>2012-07-24 09:35:44 +0100
commita7889bdd566f1dd1f98d755118c80784aeda71c6 (patch)
tree4abf0fcd81ce2fabca239f782f3a1bed922005bf /tools/configure.ac
parent8b89db92ea831eaee496184944fda38bcdd3560c (diff)
downloadxen-a7889bdd566f1dd1f98d755118c80784aeda71c6.tar.gz
xen-a7889bdd566f1dd1f98d755118c80784aeda71c6.tar.bz2
xen-a7889bdd566f1dd1f98d755118c80784aeda71c6.zip
autoconf: only check for dev86 and iasl checks on x86
The previous patch (25331:dfe39bd65137) only touched the definition of the variables used to refer to the paths to the tools but didn't remove the actual checks. Run autogen after applying this patch. Signed-off-by: Roger Pau Monne <roger.pau@citrix.com> Acked-by: Ian Campbell <ian.campbell@citrix.com> [ ijc -- added a comment about "build" vs "host" terminology and a note about the previous attempt to the changelog, reintroduce AC_CANONICAL_HOST which was remove by 25303:078c7d4cde1d after this patch was posted but is required for $host_cpu ] Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac28
1 files changed, 19 insertions, 9 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index e37d93ad3f..59b9aaffb9 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -19,6 +19,8 @@ recommended, use PREPEND_INCLUDES, PREPEND_LIB, \
APPEND_INCLUDES and APPEND_LIB instead when possible.])
])
+AC_CANONICAL_HOST
+
# M4 Macro includes
m4_include([m4/savevar.m4])
m4_include([m4/features.m4])
@@ -100,15 +102,23 @@ AS_IF([test "x$pythontools" = "xy"], [
[AC_MSG_ERROR([PYTHON specified, but is not an absolute path])])
AX_PATH_PROG_OR_FAIL([PYTHONPATH], [$PYTHON])
AX_CHECK_PYTHON_VERSION([2], [3])
- AX_CHECK_PYTHON_DEVEL()
-])
-AX_PATH_PROG_OR_FAIL([XGETTEXT], [xgettext])
-AX_PATH_PROG_OR_FAIL([AS86], [as86])
-AX_PATH_PROG_OR_FAIL([LD86], [ld86])
-AX_PATH_PROG_OR_FAIL([BCC], [bcc])
-AX_PATH_PROG_OR_FAIL([IASL], [iasl])
-AX_CHECK_UUID
-AX_CHECK_CURSES
+ AX_CHECK_PYTHON_DEVEL()
+ ])
+ AX_PATH_PROG_OR_FAIL([XGETTEXT], [xgettext])
+dnl as86, ld86, bcc and iasl are only required when the host system is x86*.
+dnl "host" here means the platform on which the hypervisor and tools is
+dnl going to run, not the platform on which we are building (known as
+dnl "build" in gnu speak).
+case "$host_cpu" in
+i[[3456]]86|x86_64)
+ AX_PATH_PROG_OR_FAIL([AS86], [as86])
+ AX_PATH_PROG_OR_FAIL([LD86], [ld86])
+ AX_PATH_PROG_OR_FAIL([BCC], [bcc])
+ AX_PATH_PROG_OR_FAIL([IASL], [iasl])
+ ;;
+esac
+ AX_CHECK_UUID
+ AX_CHECK_CURSES
PKG_CHECK_MODULES(glib, [glib-2.0 >= 2.12])
# Check library path