aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2012-07-24 09:35:44 +0100
committerIan Campbell <ian.campbell@citrix.com>2012-07-24 09:35:44 +0100
commit8b89db92ea831eaee496184944fda38bcdd3560c (patch)
tree6e31a3f9fe8ef8ee273d1a17239177e896d02cb3 /tools/configure.ac
parent151db52fd2160d99ede494ba7a56a95010a14cff (diff)
downloadxen-8b89db92ea831eaee496184944fda38bcdd3560c.tar.gz
xen-8b89db92ea831eaee496184944fda38bcdd3560c.tar.bz2
xen-8b89db92ea831eaee496184944fda38bcdd3560c.zip
autoconf: revert 25178:181478052ea2
This change only removed the variables used to supply the path to the tool but didn't remove the checks. Will be fixed properly in a subsequent patch. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index d3e0c1458e..e37d93ad3f 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -67,16 +67,10 @@ AC_ARG_VAR([CURL], [Path to curl-config tool])
AC_ARG_VAR([XML], [Path to xml2-config tool])
AC_ARG_VAR([BASH], [Path to bash shell])
AC_ARG_VAR([XGETTEXT], [Path to xgetttext tool])
-
-dnl as86, ld86, bcc and iasl are only present in x86* systems
-case "$host_cpu" in
-i[[3456]]86|x86_64)
- AC_ARG_VAR([AS86], [Path to as86 tool])
- AC_ARG_VAR([LD86], [Path to ld86 tool])
- AC_ARG_VAR([BCC], [Path to bcc tool])
- AC_ARG_VAR([IASL], [Path to iasl tool])
- ;;
-esac
+AC_ARG_VAR([AS86], [Path to as86 tool])
+AC_ARG_VAR([LD86], [Path to ld86 tool])
+AC_ARG_VAR([BCC], [Path to bcc tool])
+AC_ARG_VAR([IASL], [Path to iasl tool])
# Checks for programs.
AC_PROG_CC