aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2013-05-15 14:47:32 +0100
committerIan Campbell <ian.campbell@citrix.com>2013-08-21 10:39:20 +0100
commit5c7cbadaccca8dbb47f2c42ab1b5a8afac9275e3 (patch)
tree0f3fa769942ff67d46cb9cd6fd5dc412c6cb6656 /tools/configure.ac
parentb0f69ec5c71de1248d915c193b57c43e786857dd (diff)
downloadxen-5c7cbadaccca8dbb47f2c42ab1b5a8afac9275e3.tar.gz
xen-5c7cbadaccca8dbb47f2c42ab1b5a8afac9275e3.tar.bz2
xen-5c7cbadaccca8dbb47f2c42ab1b5a8afac9275e3.zip
tools: allow user to specify a system qemu-xen binary
If this option is given don't bother building qemu-xen ourselves. Likely to be handy for distros who have an existing qemu package which they want to reuse. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 9b05478083..1f576819a8 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -76,6 +76,27 @@ AC_DEFINE([HAVE_QEMU_TRADITIONAL], [1], [Qemu traditional enabled])
])
AC_SUBST(qemu_traditional)
+AC_ARG_WITH([system-qemu],
+ AS_HELP_STRING([--with-system-qemu@<:@=PATH@:>@],
+ [Use system supplied qemu PATH or qemu (taken from $PATH) as qemu-xen
+ device model instead of building and installing our own version]),[
+ case $withval in
+ yes) qemu_xen=n ; qemu_xen_path=qemu ;;
+ no) qemu_xen=y ; qemu_xen_path= ;;
+ *) qemu_xen=n ; qemu_xen_path=$withval ;;
+ esac
+],[
+ case "$host_cpu" in
+ i[[3456]]86|x86_64)
+ qemu_xen=y;;
+ *) qemu_xen=n;;
+ esac
+])
+AS_IF([test "x$qemu_xen" = "xn"], [
+ AC_DEFINE_UNQUOTED([QEMU_XEN_PATH], ["$qemu_xen_path"], [Qemu Xen path])
+])
+AC_SUBST(qemu_xen)
+
AC_ARG_VAR([PREPEND_INCLUDES],
[List of include folders to prepend to CFLAGS (without -I)])
AC_ARG_VAR([PREPEND_LIB],