aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2013-08-06 11:32:32 +0100
committerIan Campbell <ian.campbell@citrix.com>2013-08-21 10:32:42 +0100
commitb0f69ec5c71de1248d915c193b57c43e786857dd (patch)
tree3e1d239ee2b68d08b80fe25385da22e71d4c6bd3 /tools/configure.ac
parent874f76a86adf1da70921884f5a868eec105cf8cd (diff)
downloadxen-b0f69ec5c71de1248d915c193b57c43e786857dd.tar.gz
xen-b0f69ec5c71de1248d915c193b57c43e786857dd.tar.bz2
xen-b0f69ec5c71de1248d915c193b57c43e786857dd.zip
tools: Make qemu-xen-traditional build optional.
Now that we have upstream qemu people may want to avoid building this extra code. There is a little bit of trickery in stubdom/configure.ac to ensure that the ioemu stubdom is only built if qemu-traditional is enabled. libxl will return an error if a caller tries to build a domain using qemu-xen-traditional when this support was disabled at build time. Since qemu-xen-traditional has been historically tightly bound to the Xen releases I don't see any value in supporting "3rd party" provision of qemu-xen-traditional. We also do not want/need this on ARM therefore default is on for x86 and off otherwise. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> [ ijc -- trivial conflicts in Tools.mk.in and tools/configure.ac. Reran autogen.sh ]
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 1b4625a299..9b05478083 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -60,6 +60,22 @@ AX_ARG_DEFAULT_ENABLE([debug], [Disable debug build of tools])
AX_ARG_DEFAULT_ENABLE([xend], [Disable xend toolstack])
AX_ARG_DEFAULT_DISABLE([blktap1], [Disable blktap1 tools])
+AC_ARG_ENABLE([qemu-traditional],
+ AS_HELP_STRING([--enable-qemu-traditional],
+ [Enable qemu traditional device model, (DEFAULT is on for x86, otherwise off)]),,[
+ case "$host_cpu" in
+ i[[3456]]86|x86_64)
+ enable_qemu_traditional="yes";;
+ *) enable_qemu_traditional="no";;
+ esac
+])
+AS_IF([test "x$enable_qemu_traditional" = "xyes"], [
+AC_DEFINE([HAVE_QEMU_TRADITIONAL], [1], [Qemu traditional enabled])
+ qemu_traditional=y],[
+ qemu_traditional=n
+])
+AC_SUBST(qemu_traditional)
+
AC_ARG_VAR([PREPEND_INCLUDES],
[List of include folders to prepend to CFLAGS (without -I)])
AC_ARG_VAR([PREPEND_LIB],