aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches/100-disable_qt_tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cmake/patches/100-disable_qt_tests.patch')
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
deleted file mode 100644
index 9c0957a390..0000000000
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/Tests/RunCMake/CMakeLists.txt
-+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -375,15 +375,6 @@ else()
- message(WARNING "Could not find or build ctresalloc")
- endif()
-
--find_package(Qt4 QUIET)
--find_package(Qt5Core QUIET)
--if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)
-- add_RunCMake_test(IncompatibleQt)
--endif()
--if (QT4_FOUND)
-- add_RunCMake_test(ObsoleteQtMacros -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
--endif()
--
- find_package(PkgConfig QUIET)
- if(PKG_CONFIG_FOUND)
- add_RunCMake_test(FindPkgConfig)
---- a/Tests/CMakeLists.txt
-+++ b/Tests/CMakeLists.txt
-@@ -489,13 +489,6 @@ if(BUILD_TESTING)
-
- list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
-
-- if(NOT DEFINED CMake_TEST_Qt4)
-- set(CMake_TEST_Qt4 1)
-- endif()
-- if(CMake_TEST_Qt4 AND NOT QT4_FOUND)
-- find_package(Qt4 QUIET)
-- endif()
--
- if(CMake_TEST_Qt4 AND QT4_FOUND)
- # test whether the Qt4 which has been found works, on some machines
- # which run nightly builds there were errors like "wrong file format"