aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches/100-disable_qt_tests.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-05 15:38:32 -0700
committerHans Dedecker <dedeckeh@gmail.com>2020-04-06 20:30:18 +0200
commit8af80e79bd5b750bf9a5ab01a6ecdb3971248bae (patch)
treeef68eb881b3fd334cc3653df3bf5fc621600ebf8 /tools/cmake/patches/100-disable_qt_tests.patch
parenta0d14510884e6549a1637f69b0bb7325b280aff8 (diff)
downloadupstream-8af80e79bd5b750bf9a5ab01a6ecdb3971248bae.tar.gz
upstream-8af80e79bd5b750bf9a5ab01a6ecdb3971248bae.tar.bz2
upstream-8af80e79bd5b750bf9a5ab01a6ecdb3971248bae.zip
tools/cmake: update to 3.17.0
Remove libressl patches; they are no longer needed as LibreSSl adde support Replace qt tests patch with one that disables all of them. Refresh remaining one. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/cmake/patches/100-disable_qt_tests.patch')
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
deleted file mode 100644
index 9c0957a390..0000000000
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/Tests/RunCMake/CMakeLists.txt
-+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -375,15 +375,6 @@ else()
- message(WARNING "Could not find or build ctresalloc")
- endif()
-
--find_package(Qt4 QUIET)
--find_package(Qt5Core QUIET)
--if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)
-- add_RunCMake_test(IncompatibleQt)
--endif()
--if (QT4_FOUND)
-- add_RunCMake_test(ObsoleteQtMacros -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
--endif()
--
- find_package(PkgConfig QUIET)
- if(PKG_CONFIG_FOUND)
- add_RunCMake_test(FindPkgConfig)
---- a/Tests/CMakeLists.txt
-+++ b/Tests/CMakeLists.txt
-@@ -489,13 +489,6 @@ if(BUILD_TESTING)
-
- list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
-
-- if(NOT DEFINED CMake_TEST_Qt4)
-- set(CMake_TEST_Qt4 1)
-- endif()
-- if(CMake_TEST_Qt4 AND NOT QT4_FOUND)
-- find_package(Qt4 QUIET)
-- endif()
--
- if(CMake_TEST_Qt4 AND QT4_FOUND)
- # test whether the Qt4 which has been found works, on some machines
- # which run nightly builds there were errors like "wrong file format"