aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ccache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/ccache/Makefile')
-rw-r--r--tools/ccache/Makefile24
1 files changed, 4 insertions, 20 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index a0f6332522..76b6957780 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -23,29 +23,13 @@ define Host/Install/ccache
$(CP) ./files/* $(STAGING_DIR_HOST)/bin/
endef
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
- define Host/Clean
+define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
- endef
- define Host/Install
+endef
+define Host/Install
$(call Host/Install/Default)
$(call Host/Install/ccache)
- endef
-else
- define Host/Prepare
- endef
- define Host/Configure
- endef
- define Host/Compile
- endef
- define Host/Install
- $(call Host/Install/ccache)
- endef
- define Host/Clean
- endef
- define Download
- endef
-endif
+endef
$(eval $(call HostBuild))