aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ccache/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-14 10:30:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-14 10:30:38 +0000
commit388647b580df44a94417cb7a8cc2fc54d581f552 (patch)
treeab2af6c3f605a3a4331b6450203f8fae6b914292 /tools/ccache/Makefile
parentcf93a8f2272e2a009f06a0c231a5db95edc33042 (diff)
downloadupstream-388647b580df44a94417cb7a8cc2fc54d581f552.tar.gz
upstream-388647b580df44a94417cb7a8cc2fc54d581f552.tar.bz2
upstream-388647b580df44a94417cb7a8cc2fc54d581f552.zip
ccache: Make ccache aware of OpenWRT provided GCC patch.
The OpenWRT GCC patch, 910-mbsd_multi.patch adds an extra option to gcc that depends on an environment variable. Standard ccache is unaware of this option and therefor can produce stdout from gcc that doesn't correspond to what you would get if you actually do a direct compilation with gcc. This commit adds a patch to ccache to make it aware of the new option and removes the feature from the ccache package to use the host system's installed ccache binary. Signed-off-by: Karl Vogel <karl.vogel@gmail.com> SVN-Revision: 46364
Diffstat (limited to 'tools/ccache/Makefile')
-rw-r--r--tools/ccache/Makefile24
1 files changed, 4 insertions, 20 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index a0f6332522..76b6957780 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -23,29 +23,13 @@ define Host/Install/ccache
$(CP) ./files/* $(STAGING_DIR_HOST)/bin/
endef
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
- define Host/Clean
+define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
- endef
- define Host/Install
+endef
+define Host/Install
$(call Host/Install/Default)
$(call Host/Install/ccache)
- endef
-else
- define Host/Prepare
- endef
- define Host/Configure
- endef
- define Host/Compile
- endef
- define Host/Install
- $(call Host/Install/ccache)
- endef
- define Host/Clean
- endef
- define Download
- endef
-endif
+endef
$(eval $(call HostBuild))