aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/nasm
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/nasm')
-rw-r--r--toolchain/nasm/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/toolchain/nasm/Makefile b/toolchain/nasm/Makefile
index 8d071033c7..31166358fd 100644
--- a/toolchain/nasm/Makefile
+++ b/toolchain/nasm/Makefile
@@ -24,9 +24,11 @@ HOST_CONFIGURE_ARGS+= \
--disable-gdb \
$(SOFT_FLOAT_CONFIG_OPTION) \
-HOST_MAKE_FLAGS = \
- AR=ar \
- RANLIB=ranlib
+ifeq ($(HOST_OS),Darwin)
+ HOST_MAKE_FLAGS = \
+ AR=ar \
+ RANLIB=ranlib
+endif
define Host/Prepare
$(call Host/Prepare/Default)