aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/nasm
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-07-08 12:48:13 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-07-08 14:22:54 +0200
commite204717ef2445fc848b0a70374b03b1c8484d176 (patch)
treed43913d4f037ef3b34492b7915b2e700783ab386 /toolchain/nasm
parent79b38047b9962846912195b963230653c35900a1 (diff)
downloadupstream-e204717ef2445fc848b0a70374b03b1c8484d176.tar.gz
upstream-e204717ef2445fc848b0a70374b03b1c8484d176.tar.bz2
upstream-e204717ef2445fc848b0a70374b03b1c8484d176.zip
toolchain/nasm: force ar and ranlib only on macOSX
On Debian 9 nasm does not build when we force it to use ranlib, for macOSX this is needed. Only force this on macOSX and not on any other OS, this should fix the build of nasm on Linux systems. On my Debian system the nasm configure script selects gcc-ranlib and gcc-ar instead. Fixes: d3a7587eb95 ("toolchain/nasm: fix missing AR/RANLIB variables") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain/nasm')
-rw-r--r--toolchain/nasm/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/toolchain/nasm/Makefile b/toolchain/nasm/Makefile
index 8d071033c7..31166358fd 100644
--- a/toolchain/nasm/Makefile
+++ b/toolchain/nasm/Makefile
@@ -24,9 +24,11 @@ HOST_CONFIGURE_ARGS+= \
--disable-gdb \
$(SOFT_FLOAT_CONFIG_OPTION) \
-HOST_MAKE_FLAGS = \
- AR=ar \
- RANLIB=ranlib
+ifeq ($(HOST_OS),Darwin)
+ HOST_MAKE_FLAGS = \
+ AR=ar \
+ RANLIB=ranlib
+endif
define Host/Prepare
$(call Host/Prepare/Default)