aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-5.4
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/patches-5.4')
-rw-r--r--target/linux/x86/patches-5.4/011-tune_lzma_options.patch10
-rw-r--r--target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch7
-rw-r--r--target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch4
3 files changed, 11 insertions, 10 deletions
diff --git a/target/linux/x86/patches-5.4/011-tune_lzma_options.patch b/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
index 09d3c6c7ce..de9d4421a6 100644
--- a/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
+++ b/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
@@ -1,14 +1,14 @@
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -325,7 +325,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -342,7 +342,7 @@ quiet_cmd_bzip2 = BZIP2 $@
+ # ---------------------------------------------------------------------------
quiet_cmd_lzma = LZMA $@
- cmd_lzma = (cat $(filter-out FORCE,$^) | \
-- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-+ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
- (rm -f $@ ; false)
+- cmd_lzma = { cat $(real-prereqs) | lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@
++ cmd_lzma = { cat $(real-prereqs) | lzma e -lc8 -eos -si -so; $(size_append); } > $@
quiet_cmd_lzo = LZO $@
+ cmd_lzo = { cat $(real-prereqs) | lzop -9; $(size_append); } > $@
--- a/arch/x86/include/asm/boot.h
+++ b/arch/x86/include/asm/boot.h
@@ -24,7 +24,7 @@
diff --git a/target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch b/target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch
index c3a7fce9ce..d4de2027ba 100644
--- a/target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch
+++ b/target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch
@@ -1,12 +1,13 @@
---- a/drivers/clocksource/cs5535-clockevt.c
-+++ b/drivers/clocksource/cs5535-clockevt.c
-@@ -130,7 +130,8 @@ static irqreturn_t mfgpt_tick(int irq, v
+--- a/drivers/clocksource/timer-cs5535.c
++++ b/drivers/clocksource/timer-cs5535.c
+@@ -127,7 +127,9 @@ static irqreturn_t mfgpt_tick(int irq, v
cs5535_mfgpt_write(cs5535_event_clock, MFGPT_REG_SETUP,
MFGPT_SETUP_CNTEN | MFGPT_SETUP_CMP2);
- cs5535_clockevent.event_handler(&cs5535_clockevent);
+ if (cs5535_clockevent.event_handler)
+ cs5535_clockevent.event_handler(&cs5535_clockevent);
++
return IRQ_HANDLED;
}
diff --git a/target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch b/target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch
index ef2e1333e7..a83ee3b6b8 100644
--- a/target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch
+++ b/target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch
@@ -1,6 +1,6 @@
--- a/drivers/hwmon/w83627ehf.c
+++ b/drivers/hwmon/w83627ehf.c
-@@ -2717,8 +2717,8 @@ static int __init w83627ehf_find(int sio
+@@ -2704,8 +2704,8 @@ static int __init w83627ehf_find(int sio
static const char sio_name_W83627UHG[] __initconst = "W83627UHG";
static const char sio_name_W83667HG[] __initconst = "W83667HG";
static const char sio_name_W83667HG_B[] __initconst = "W83667HG-B";
@@ -11,7 +11,7 @@
u16 val;
const char *sio_name;
-@@ -2762,14 +2762,14 @@ static int __init w83627ehf_find(int sio
+@@ -2749,14 +2749,14 @@ static int __init w83627ehf_find(int sio
sio_data->kind = w83667hg_b;
sio_name = sio_name_W83667HG_B;
break;